Status usług / nowości

Ważna aktualizacja oprogramowania

9 listopada 2020 23:20

Harmonogram aktualizacji

Serwery będą aktualizowane partiami - oto informacja, w którym dniu odbędą się prace na wybranych serwerach:

- 16.11.2020 00:30: s0, s1, s2, s3, s4, s5, s6, s7, s8, s9, s10 s11;

- 17.11.2020 00:30: s12, s13, s14, s15, s16, s17, s18, s19, s20, s21, s22, s23, s24, s25, s26, s27, s28, s29, s30;

- 18.11.2020 00:30: s31, s32, s33, s34, s35, s36, s37, s38, s39, s40, s41, s42, s43, s44, s45, s46, s47, s48, s49, s50;

Wykonany zostanie również restart systemu - prosimy upewnić się, że wszystkie aplikacje, które mają uruchomić się automatycznie po restarcie są dodane do zadań cron.

Aplikacje uruchomione przez użytkowników ze względu na aktualizacje w systemie mogą wymagać ponownej kompilacji lub rekonfiguracji.

Przerwy w działaniu mogą potrwać do godziny 02:00. Za utrudnienia przepraszamy.


OpenSSL

Informujemy, że zostanie zaktualizowna wersja biblioteki OpenSSL co będzie wymagać ponownej kompilacji oprogramowania własnego użytkowników (dotyczy to również aplikacji opartych o Python, Ruby, Node.js) , które korzysta z OpenSSL zainstalowanego w systemie.


PHP

Zgodnie z zapowiedziami przypominamy, że ulegnie zmianie domyślna wersja PHP z 7.1 na 7.3. Zmiana obejmie zarówno wersję PHP dla CLI jak i dla stron. Zmiana wersji dotyczy również aktywnych stron. W razie potrzeby utrzymania działania stron i aplikacji na PHP 7.1 proponujemy przełączyć wersję PHP już teraz:

https://wiki.mydevil.net/PHP#Wersja_PHP


Python 3.9

Po aktualizacji pojawi się dodatkowa wersja Python 3.9. Domyślną wersją pozostaje Python 3.6.

Jeżeli po aktualizacji oprogramowania wystąpi problem z działaniem lub uruchomieniem aplikacji Python (ze względu na zmiany wersji systemowych bibliotek) to będzie oznaczać, że mogą one wymagać rekonfiguracji. Logi błędów znajdują się w katalogu ~/domains/NAZWA_DOMENY/logs/error.log, proponujemy zapoznać się z nimi w razie wystąpienia problemu.


Node.js 14 i 15

Zgodnie z zapowiedzią Node.js w wersjach 6 oraz 8 zostaną usunięte podczas aktualizacji. Aplikacje korzystające z tych wersji zostaną przełączone automatycznie na Node.js 10.

Nową wersją domyślną zostanie Node.js 12.

Zgodnie z wcześniejszym powiadomieniem prosimy upewnić się, że uruchomione strony są kompatybilne z nowszymi wersjami Node.js.

Aplikacje Node.js mogą wymagać rekonfiguracji po aktualizacji systemu.

Nowością będą dwie wersje Node.js: 14 oraz 15.

Dostępne wersje Node.js po aktualizacji: 10, 12 (nowa domyślna), 14 oraz 15.

Jeżeli po aktualizacji wystąpi problem z działaniem lub uruchomieniem aplikacji Node.js to będzie oznaczać, że mogą one wymagać rekonfiguracji. Logi błędów znajdują się w katalogu ~/domains/NAZWA_DOMENY/logs/error.log, proponujemy zapoznać się z nimi w razie wystąpienia problemu.


Ruby

Gemy mogą wymagać przebudowania ze względu na zmiany wersji systemowych bibliotek - bez tego aplikacje oparte o Ruby, Ruby on Rails mogą nie zadziałać prawidłowo po aktualizacji (dotyczy to również m.in. Redmine).

Jeżeli po aktualizacji oprogramowania wystąpi problem z działaniem lub uruchomieniem aplikacji Ruby to będzie oznaczać, że mogą one wymagać rekonfiguracji. Logi błędów znajdują się w katalogu ~/domains/NAZWA_DOMENY/logs/error.log, proponujemy zapoznać się z nimi w razie wystąpienia problemu.


W razie problemów prosimy o skontaktowanie się z nami bezpośrednio poprzez system ticketów dostępnym w panelu płatności lub adres e-mail: pomoc@mydevil.net

Wiadomość e-mail musi zostać wysłana z adresu kontaktowego dla usługi (w panelu płatności można dodać techniczne adresy kontaktowe) jak i zawierać jak najwięcej informacji o problemie (jakiej aplikacji lub strony WWW dotyczy problem).

Dodaj komentarz


~admin, Techniczne

Komentarze

pogotowie-it

9 listopada 2020 23:53

Zapraszam po -20% zniżki :-)
Wystarczy użyć linka http://mydevil.net/pp/BD8PHCWSY3 lub użyć kodu: BD8PHCWSY3 w czasie składania zamówienia

DODATKOWO TANIEJ 20%

10 listopada 2020 01:02

DODATKOWO 20%! TANIEJ Z KODEM:
G471XQDHJQ

lub link:

http://www.mydevil.net/pp/G471XQDHJQ

20 % taniej z kodem V49ER058C2

10 listopada 2020 08:01

20 % taniej z kodem V49ER058C2

Jak ktoś chce to tu jeszcze kod dodatkowy na -20%, V49ER058C2
UWAGA! Działa łacznie z innymi promocjami dla nowych klientów!

http://www.mydevil.net/pp/V49ER058C2

Marcel

16 listopada 2020 01:04

>>> 20% zniżki <<<Serdecznie polecam zarejestrować się z kodem B1HWZDAM53 lub użyć link http://mydevil.net/pp/B1HWZDAM53 aby otrzymać 20% zniżki na każdą usługę.

k

16 listopada 2020 02:36

2:30, nadal wszystko lezy na s0, zero info o problemach i nowej ety

admin

16 listopada 2020 03:32

@k prace zostały zakończone.

bas

17 listopada 2020 08:36

Na kiedy przewidujecie koniec prac z s29 ?

admin

17 listopada 2020 09:04

@bas prace były zakończone w nocy.

bas

17 listopada 2020 09:11

@admin dziękuje za odpowiedź

Tackgnol

18 listopada 2020 16:44

Hej Pythong wali
ImportError: Shared object "libffi.so.6" not found, required by "_cffi_backend.so"

Ktoś tak miał wie jak naprawić?

admin

19 listopada 2020 10:57

@Tackgnol sprawdzić error.log, przekompilować/przeinstalować moduł python który zgłasza ten problem.

mm

19 listopada 2020 11:51

@Tackgnol mam to samo, działam z tym włąśnie...

mm

19 listopada 2020 12:22

@Tackgnol u mnie pomogło:

`$ python -m pip uninstall cffi`
`$ python -m pip install cffi`

Tackgnol

19 listopada 2020 16:31

@admin Error właśnie z loga pełen error:
Traceback (most recent call last):
File "/usr/local/lib/ruby/gems/2.5/gems/passenger-6.0.6/src/helper-scripts/wsgi-loader.py", line 379, in <module>
app_module = load_app()
File "/usr/local/lib/ruby/gems/2.5/gems/passenger-6.0.6/src/helper-scripts/wsgi-loader.py", line 80, in load_app
return imp.load_source('passenger_wsgi', startup_file)
File "/usr/home/Tackgnol/.virtualenvs/dev_homepage/lib/python3.7/imp.py", line 171, in load_source
module = _load(spec)
File "<frozen importlib._bootstrap>", line 696, in _load
File "<frozen importlib._bootstrap>", line 677, in _load_unlocked
File "<frozen importlib._bootstrap_external>", line 728, in exec_module
File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
File "/usr/home/Tackgnol/domains/adamkoscielniak.eu.org/public_python/passenger_wsgi.py", line 3, in <module>
from main import app as application
File "/usr/home/Tackgnol/domains/adamkoscielniak.eu.org/public_python/main.py", line 24, in <module>
import Controllers.User
File "/usr/home/Tackgnol/domains/adamkoscielniak.eu.org/public_python/Controllers/User.py", line 6, in <module>
from Utils.Encryption import hashPassword, checkPassword
File "/usr/home/Tackgnol/domains/adamkoscielniak.eu.org/public_python/Utils/Encryption.py", line 1, in <module>
from bcrypt import hashpw, checkpw, gensalt
File "/usr/home/Tackgnol/.virtualenvs/dev_homepage/lib/python3.7/site-packages/bcrypt/__init__.py", line 25, in <module>
from bcrypt import _bcrypt
ImportError: Shared object "libffi.so.6" not found, required by "_cffi_backend.so"

@mm
ale na venvie? Dostaje pemission denied ;(

admin

19 listopada 2020 16:39

@Tackgnol

Tak, musisz przebudować moduł w swoim virtualenv.

Tackgnol

19 listopada 2020 18:52

@admin
dzięki działa!

CSTI

19 listopada 2020 22:50

public_ruby/vendor/cache/ruby/2.5.0/gems/mysql2-0.5.3/lib/mysql2/mysql2.so: [BUG] Segmentation fault at 0x0000000000000000 i tak z każdą próbą uruchomienia ponownie projektu w RoR.....

Hylu

19 listopada 2020 22:55

@CSTI Użyj nowszej wersji Ruby, np. chociaż 2.6.4 lub 2.4.10.

CSTI

19 listopada 2020 23:56

@Hylu - zarówno z 2.6.4 jak i 2.4.10 błąd ten sam.....

Hylu

19 listopada 2020 23:57

Usunąłeś i dodałeś stronę w panelu ze wskazaniem na nowe Ruby?

CSTI

20 listopada 2020 00:43

@Hylu - nawet do tego miejsca nie mogę dotrzeć - np: przy wywołaniu RAILS_ENV=production bundle exec rake generate_secret_token wyrzuca błąd. Raz udało się przejść cały proces budowania i tak jak pisałeś - usunąłem i dodałem stronę ze wskazaniem na nowe ruby - i ten sam błąd

admin

20 listopada 2020 18:17

@CSTI jeżeli mowa o Redmine to nie musisz wykonywać wskazanych kroków a:
bundle install --without development test
Na jakiej wersji Ruby był zainstalowany Redmine poprzednio?
Może się okazać, że nie obędzie się bez:
https://www.redmine.org/projects/redmine/wiki/RedmineUpgrade

Czy masz dodane jakieś eksporty w .bash_profile dotyczące kompilatora?

BRUDA

22 listopada 2020 09:34

Dodatkowy kod na -20% na WSZYSTKIE usługi w mydevil : PY7UKOCAKB

Przy składaniu zamówienia skorzystaj koniecznie z kodu rabatowego: PY7UKOCAKB

Cena Twojej usługi zmaleje o DODATKOWE -20% !!!

Dodaj komentarz

Zasubskrybuj

Jeśli chcesz otrzymywać powiadomienia o nowościach na swój adres e-mail, zapisz się na naszą listę subskrybentów! Wystarczy podać swój adres w poniższym formularzu.

Twitter

MyDevil.net @MyDevilnet - 9 listopada 2020 22:42
Ważna aktualizacja oprogramowania -> https://t.co/bxLmSfjSp1 #mydevil #mydevilnet

Zasubskrybuj

Zapisz się do naszego newslettera aby być na bieżąco z nowościami.




logo Atman
logo Etop
logo PayU
logo PayPal
logo Nginx
logo Passenger
logo Python
logo Django
logo FreeBSD
logo MySQL
logo OpenZFS
logo Git