Status usług / nowości

Minimalna wersja TLS i unaccent dla PostgreSQL

25 lipca 2022 22:53

Opcja minimalnej wersji TLS dla połączeń HTTPS

Udostępniliśmy możliwość wyboru minimalnej wersji TLS dla połączeń HTTPS dla każdej domeny z osobna.

Dla dotychczas istniejących domen opcja ustawiona jest na TLS 1.0 (akceptowane połączenia TLS 1.0, 1.1, 1.2 oraz 1.3).
Dla nowych domen opcja ustawiana będzie na TLS 1.2 (akceptowane połączenia TLS 1.2 oraz 1.3).
Zalecana przez nas wersja TLS to minimum 1.2.
TLS 1.0 zapewnia największą kompatybilność ze starszym oprogramowaniem, ale mniejsze bezpieczeństwo transmisji danych.

Składnia polecenia:

devil www options <DOMENA> tls_min <WERSJA>


Gdzie:

DOMENA oznacza domenę WWW
WERSJA oznacza minimalną akceptowaną wersje TLS przez nasz serwer, akceptowane wartości: 1.0, 1.1, 1.2, 1.3.

Opcja dostępna jest również w panelu DevilWEB:

Strony WWW (WWW Websites) ➡ Szczegóły (Details) ➡ Minimalna wersja TLS (Minimal TLS version support) ➡ należy wybrać minimalną wersję TLS z listy oraz zapisać zmiany przyciskiem Zapisz zmiany (Save changes).


Rozszerzenie unaccent dla PostgreSQL

Kolejną nowością jest możliwość korzystania z rozszerzenia unaccent dla serwera PosgreSQL.

Aby aktywować rozszerzenie dla wybranej bazy danych należy wykonać polecenie:
devil pgsql extensions NAZWA_BAZY unaccent

lub przy pomocy panelu DevilWEB:

PostgreSQL ➡ Rozszerzenia (Extensions) - przy wybranej bazie danych należy wybrać Instaluj (Install) przy rozszerzeniu unaccent.

Zobacz komentarze (3)


~admin, Nowości

Wakacyjna promocja i Composer 2

24 czerwca 2022 20:51

Promocja "Wakacje z MyDevil.net 2022"

Przygotowaliśmy dla Was promocję "Wakacje z MyDevil.net 2022" obniżającą cenę nowych kont hostingowych MyDevil.net (MD1, MD2, MD3, MD4) o 50%.
Oferta promocyjna startuje 24.06.2022 o godzinie 20:40 i trwa do 31.08.2022 godziny 23:59 lub osiągnięcia limitu 5000 nowych kont hostingowych. Promocja łączy się z kodami polecającymi: zapraszamy do dzielenia się swoimi kodami z osobami, które chciałyby zakupić nowe konto hostingowe na MyDevil.net.

Regulamin promocji:
https://www.mydevil.net/regulaminy-i-dokumenty,49.html

Composer 2

Udostępniliśmy Composer 2 - system zarządzania pakietami dla języka PHP. Działa z wersjami PHP: 7.2, 7.3, 7.4, 8.0 i 8.1. Dostępny pod poleceniem: composer2
Composer 1 nadal jest dostępny i działa ze wszystkimi wersjami PHP od 5.6 do 8.1. Dostępny pod poleceniem: composer

W przyszłości Composer 1 zostanie całkowicie zastąpiony przez Composer 2.

Zobacz komentarze (8)


~admin, Informacje

PHP 8.1

16 maja 2022 19:02

Informujemy o udostępnieniu najnowszej wersji PHP 8.1 na serwerach MyDevil.net.
Jest to kolejna wersja PHP obok 5.6, 7.0, 7.1, 7.2, 7.3 (domyślna), 7.4, 8.0 dostępna na naszym hostingu.
Aby aktywować PHP 8.1 dla stron wystarczy dodać do pliku .htaccess wpis:
AddType application/x-httpd-php81 .php

Wersja PHP dla CLI jest natomiast dostępna pod poleceniem php81.

Zobacz komentarze (8)


~admin, Nowości

Promocja "Wielkanoc z MyDevil.net 2022"

16 kwietnia 2022 00:04

Promocja "Wielkanoc z MyDevil.net 2022"

Zapraszamy Was do wzięcia udziału w corocznej Świątecznej promocji "Wielkanoc z MyDevil.net 2022" obniżającej cenę nowych jak i przedłużanych kont hostingowych oraz VPN o 40%.

Promocja startuje 15.04.2022 o godzinie 23:59, kończy się 19.04.2022 o godzinie 23:59 lub po osiągnięcia limitu 500 transakcji objętych promocją za konta hostingowe i VPN.

Promocja łączy się z kodami polecającymi, nie łączy się z programem lojalnościowym.

Zapraszamy do dzielenia się swoimi kodami polecającymi ze znajomymi!


Wesołych Świąt życzy administracja MyDevil.net.


Regulamin promocji:

https://www.mydevil.net/regulaminy-i-dokumenty,48.html


Zobacz komentarze (12)


~admin, Informacje

Aktualizacja systemu i MySQL 8.0

13 marca 2022 12:32

Harmonogram aktualizacji

Serwery będą aktualizowane partiami - oto informacja, w którym dniu odbędą się prace na wybranych serwerach:

- 18.04.2022 00:30: s0, s1, s2, s3, s4, s5, s6, s7, s8, s9, s10, s11, s12, s13, s14, s15;

- 19.04.2022 00:30: s16, s17, s18, s19, s20, s21, s22, s23, s24, s25, s26, s27, s28, s29, s30, s31, s32, s33, s34, s35;

- 20.04.2022 00:30: s36, s37, s38, s39, s40, s41, s42, s43, s44, s45, s46, s47, s48, s49, s50, s51, s52, s53, s54;

Wykonany zostanie również restart systemu - prosimy upewnić się, że wszystkie aplikacje, które mają uruchomić się automatycznie po restarcie są dodane do zadań cron.

Aplikacje uruchomione przez użytkowników ze względu na aktualizacje w systemie mogą wymagać ponownej kompilacji lub rekonfiguracji.

Przerwa w działaniu usług może wynieść do czterech godzin. Za utrudnienia przepraszamy.


Aktualizacja MySQL do 8.0

W trakcie aktualizacji zostanie wykonana zmiana wersji serwera baz MySQL z 5.7 do 8.0. Prosimy upewnić się czy już uruchomione aplikacje zadziałają poprawnie z nową wersją baz danych. Jeżeli nie zadziałają prawidłowo z MySQL 8.0, to bez dostosowania aplikacji/ich aktualizacji po stronie użytkownika nie będzie możliwości ich uruchomienia na naszym hostingu.


Python

Po aktualizacji nową domyślną wersją Python będzie wersja 3.8. Wsparcie dla wersji 3.5 zostanie usunięte.

Jeżeli po aktualizacji oprogramowania wystąpi problem z działaniem lub uruchomieniem aplikacji Python (ze względu na zmiany wersji systemowych bibliotek) to będzie oznaczać, że mogą one wymagać rekonfiguracji. Logi błędów dla aplikacji webowych znajdują się w katalogu ~/domains/NAZWA_DOMENY/logs/error.log - proponujemy zapoznać się z nimi w razie wystąpienia problemu.


Node.js

Pojawią się nowe wersje Node.js: 16 oraz 17. Zostanie usunięta wersja 15. Nową wersją domyślną zostanie Node.js 14.

Prosimy upewnić się, że uruchomione aplikacje są kompatybilne z nowszymi wersjami Node.js.

Aplikacje Node.js mogą wymagać rekonfiguracji po aktualizacji systemu.

Jeżeli po aktualizacji wystąpi problem z działaniem lub uruchomieniem aplikacji Node.js to będzie oznaczać, że mogą one wymagać rekonfiguracji. Logi błędów dla aplikacji webowych znajdują się w katalogu ~/domains/NAZWA_DOMENY/logs/error.log - proponujemy zapoznać się z nimi w razie wystąpienia problemu.


Ruby

Gemy mogą wymagać przebudowania ze względu na zmiany wersji systemowych bibliotek - bez tego aplikacje oparte o Ruby/Ruby on Rails mogą nie zadziałać prawidłowo po aktualizacji (dotyczy to również m.in. Redmine). W przypadku starszych aplikacji opartych o Ruby może być wymagana ich modyfikacja i dostosowanie do nowych wersji oprogramowania.

Jeżeli po aktualizacji oprogramowania wystąpi problem z działaniem lub uruchomieniem aplikacji Ruby to będzie oznaczać, że mogą one wymagać rekonfiguracji. Logi błędów dla aplikacji webowych znajdują się w katalogu ~/domains/NAZWA_DOMENY/logs/error.log - proponujemy zapoznać się z nimi w razie wystąpienia problemu.


Java

Zostanie zakończone wsparcie dla Java 7.


W razie problemów prosimy o skontaktowanie się z nami bezpośrednio poprzez system ticketów dostępnym w panelu płatności lub adres e-mail: pomoc@mydevil.net po uprzedniej analizie problemu z pliku error.log.

Wiadomość e-mail musi zostać wysłana z adresu kontaktowego dla usługi (w panelu płatności można dodać techniczne adresy kontaktowe) oraz zawierać jak najwięcej informacji o problemie (jakiej aplikacji lub strony WWW dotyczy problem).

Zobacz komentarze (12)


~admin, Techniczne


Strona 1 / 42

Zasubskrybuj

Jeśli chcesz otrzymywać powiadomienia o nowościach na swój adres e-mail, zapisz się na naszą listę subskrybentów! Wystarczy podać swój adres w poniższym formularzu.

Twitter

MyDevil.net @MyDevilnet - 25 lipca 2022 20:57
Minimalna wersja TLS i unaccent dla PostgreSQL -> https://t.co/b4ns9IoiEW #mydevilnet #mydevil #hosting

MyDevil.net @MyDevilnet - 24 czerwca 2022 19:06
Wakacyjna promocja na konta hostingowe MyDevil jak i Composer 2 -> https://t.co/utKW6uONBm #mydevilnet #mydevil #hosting

Zasubskrybuj

Zapisz się do naszego newslettera aby być na bieżąco z nowościami.




logo Atman
logo Etop
logo PayU
logo PayPal
logo Nginx
logo Passenger
logo Python
logo Django
logo FreeBSD
logo MySQL
logo OpenZFS
logo Git